This document lists features and changes to the current version of the software that are different from the User Guide and on-line help.

The current version of the 32 bit edition of Race Timer (Timer32.exe) is 3.09. The 16 bit edition of Race Timer (Timer16.exe) is frozen at version 1.20 and will not be updated from this point.  The version described in the User Guide is version 1.08. To see what version you have, open up the About dialog box.

Changed the default Configuration state to Admin menus on (Changed version 3.09)

When running Race Timer for the first time from a folder that does not have a set of status files, Race Timer creates a default set of status files. The default now is for the Admin menus to be on.

Renamed Configure File Format dialog to Time File Setup (Changed version 3.09)

The Configure File Format dialog is now called the Time File Setup dialog. This is consistent with the name of the menu item Time File Setup under the File menu that accesses the dialog.

Support ability to save time files in the Jaguar (Innovative Timing Systems) format (Added version 3.09)

You can now select Jaguar as the file type in the Time File Setup dialog. This allows you to import time data into the Jaguar software. The file format is:

5,23,23,”12:34:56”,M

Antenna #, Bib #, Bib #, “Time as string HH:MM:SS”, M for Manual
Conforms with Windows 7 Application Data Folder (Added version 3.08)

Windows 7 (and Vista) does not like programs creating files in the Program Files folder. Race Timer now stores the start file, the calibration file, the age group file and the backup time file in the application data Folder. If you open the About dialog box (accessed under the Help menu in Race Timer), you can see the path to the folder that you are running Race Timer from and also the path where Race Timer stores the status files.

Removed Include Participant Data option from Time File Format (version 3.08)

The check box “Include Participant Data in File” in the Configure File Format dialog no longer exists. Considering it is preferable to save a participant file with time data, this feature is redundant, confusing and obsolete.
Queue up Bib # (Added version 3.07)

Race Timer now supports queuing bib numbers (3 max) for later retrieval when recording a time.

To queue a bib number, type in the bib number then press the Q key. To pull the bib number out of the queue, record a time. The queue is a first in first out stack.
For example without queuing, if a group of three participants are approaching the finish line and are very close together, you can only type in the first person’s bib number and then wait for them to cross the finish line. If the second and third participants follow in close succession, you typically do not have a chance to type in the bib number for the second and third participant. With queuing, you can type in all three bib numbers before they reach the finish line. Then record the times when they cross the finish line and the bib numbers get pulled from the queue.
Queuing does not work when in Dual Timing mode.

Open/Load Time File (Added version 3.07)

You can now open or load Pocket Timer format time files in addition to Race Director format time files. Any other format time files are not supported.
Copy to Clipboard (Fixed version 3.07)

The Copy to Clipboard action now works correctly for all the different time file formats. Previously, it only worked correctly for Generic, Pocket Timer and Race Director formats. Prior to version 3.07, when the current time file type was set at anything else, copying to the clipboard had unpredictable results and could lead to a fatal error.

Participant File Format (Changed version 3.06)

The Participant File now has 2 new fields, the Wave Offset in hundredths of seconds and an Add/Subtract flag. 0 indicates adding the Wave Offset to the recorded time, 1 indicates subtracting the Wave Offset from the recorded time. The Participant File Format for loading is:

Bib #, First Name, Last Name, Age, Sex, City, State, Info, Address, Zip Code, Wave Offset, Add/Subtract Wave Flag, Time in Hundredths

When Saving the Participant File with time and place data:

Bib #, First Name, Last Name, Age, Sex, City, State, Info, Address, Zip Code, Wave Offset, Add/Subtract Wave Flag, Time in Hundredths, Time in HH:MM:SS.HD format, Overall Place, Age Group Place

Edit Participants Dialog (Added version 3.06)

Race Timer now allows you to enter a Wave Offset time for each participant. The Sex field now allows a third sex ‘O’ for other or unknown or mixed or whatever. This is to support mixed sex teams or unknown sex or perhaps a different event.

Save Participant File (Added version 3.06)

The Save Participant Dialog now has a check box to indicate if you want to correct times with the Wave Offset.

Save Participant File (Fixed version 3.05)

Fixed a fatal error that occurs when saving a participant file when there are no participants previously loaded or created.

Load Participant File (Fixed version 3.04)

Fixed a fatal error that occurs when loading a participant file that is missing the newline character at the end of the file.

Added Time File Format for Run Score Software (Added version 3.03)

Race Timer now allows saving of time files compatible with Run Score race management software. This file format is very simple and is just bib number followed by time in a text file.

123
12:34:56

321
12:34:57

0
12:34:58

If the bib number is unknown, then the file contains the number 0 for the bib number.

Edit Participants Dialog (Fixed version 3.02)

Fixed a fatal error that occurs when deleting the first participant in the list.

Open/Load Time File Dialog (Added version 3.01)

Race Timer now has a dialog box that allows you to choose what to do with previously recorded times (either clear them out or keep them) when loading (importing) times from a file. You can also just load times that are slower than the current last recorded time when you are keeping existing times. This is handy when doing results processing on a second computer.

Browse button in Save Participant File dialog box (Fixed version 3.01)

The Browse button now brings up a Save File dialog where you can specify a file name.

Participant File Saving (Added version 3.00)

Race Timer now supports saving participant files. To save participants, when in administrator menu mode, select Save Participant File As from the File menu.

Participant Editing (Added version 3.00)

Race Timer now supports creating and editing participants. To edit participants, when in administrator menu mode, select Edit Participants from the Action menu.

Age Group Editing (Added version 3.00)

Race Timer now supports creating and editing age groups. To edit age groups, when in administrator menu mode, select Edit Age Groups from the Action menu.

Time File Loading (Added version 3.00)

Race Timer now supports the opening and loading of existing (previously saved) time files. To load a previously saved time file, when in administrator menu mode, select Open/Load Time File from the File menu. The time file must have been saved in Race Director format.

DAG System File Format (added in version 2.11)

Race Timer now supports saving time data in a file format that is compatible with the DAG timing system. To access the DAG file format, when in administrator menu mode, select File Setup from the File menu. In the Configure File Format dialog, specify the File Type as DAG System.

Fixed Automatic Saving Save New bug (fixed in version 2.11)

When doing automatic saving and specifying Save New Times with each Save, no times where saved and the last recorded time would loose its associated bib number. This has been fixed and works correctly in version 2.11.

Automatic Setup, Install, Uninstall (added in version 2.10)

Race Timer now has a full-featured installation program that automatically copies all program files and documentation files onto your computer. It also creates a desktop shortcut and start menu items. When installing under Windows Vista, you must wade through all the prompts to permit running an unsigned program from an unknown publisher.

Known Problems with Race Timer under Windows Vista: (tested version 2.10)

Race Timer runs under Windows Vista, but some features do not work or work differently depending upon your configuration. Windows Vista no longer includes the Windows Help program, WinHlp32.exe required to view the Race Timer help file, Timer.hlp. If you wish to view the Race Timer help file and are running Windows Vista, you need to install WinHlp32.exe. You can get it directly from an update from Microsoft at:

http://www.microsoft.com/downloads/details.aspx?FamilyId=6EBCFAD9-D3F5-4365-8070-334CD175D4BB&displaylang=en
Another known problem is Race Timer’s ability to turn off the display screen to save battery power. This feature does not seem to work or works only briefly under Windows Vista. Race Timer’s ability to be always on top preventing switching to and running other programs does not work as well under Windows Vista as it did under previous versions. Consequently, when running Race Timer under Windows Vista, take care to not switch to other programs interrupting a timing session. There may be other non-critical problems that we are not aware of.
Reorganized Dialog boxes (added in version 2.00)

The dialog boxes for specifying customization parameters have been reorganized for consistency between the 32 bit edition of Race Timer (Timer32.exe) with the edition for the Pocket PC (TimerPPC.exe). Parameters associated with File attributes and File format are now under the File menu. There is now a File Setup menu item and a Automatic Saving menu item under the File menu. These menu items bring up dialog boxes for configuring the File format and automatic saving respectfully. There is still a Configuration dialog box under the Customize menu.

Ability to simplify the main screen and hide all the Action buttons (added in version 2.00)

When in Administrator menu mode, you can toggle the main screen layout from standard or to a simple format that hides all the action buttons. When the action buttons are hidden, the format of the time, bib number and list of recorded places are in the larges boldest font possible. This allows for easy viewing of the information at the finish line.

Standard method for specifying the name and location of time file (added version 2.00)

There is a Save As menu item under the File menu. This menu item brings up a standard Save As dialog box allowing you to specify the name and location of your choosing for the time file.

Ability to choose location and name of participant file (added in version 2.00)

You can now specify the location and the name of the announcer or participant file. The Open Participant File menu item under the File menu brings up a standard File Open dialog box.

Ability to turn off the video screen to save battery power (added in version 2.00)

When in Administrator menu mode, you can turn off the video screen by pressing the F5 key. Turning off the video screen can save power and extend battery life. During long periods of time when there are no finishers, you can save power by turning off the screen. To turn the screen back on, you can move the mouse or press a key such as the up or down arrow key. Remember, the computer and program is still running, so pressing a key such as the Enter key will cause the associated action such as recording a time, besides turning the screen back on.

Ability to save participant data with time and place data (added in version 2.00)

If you load a announcer or participant file, you can choose to have participant data saved in the time files for select times where bib numbers match participant bib numbers.

Standard System Menu with Close, Minimize, Maximize (added in version 1.23)

You can now close, minimize and maximize the Race Timer main program window using the standard system menu. The ability to minimize is disabled if the Always on Top feature in the Customize menu is checked.

Preservation of User Preferences between sessions (added in version 1.23)

User preferences such as Windows size, Administration menu, Always on Top, Long Labels, etc are preserved between sessions. Next time you run Race Timer all user preferences and customize options will be exactly the way you set them in the previous session.

Double clicking time in list allows quick editing (added in version 1.23)

Double clicking the mouse on an item in the Place and Time list will bring up a dialog box that allows you to edit the time and bib number for that place.

Ability to Copy Time data to Clipboard (added in version 1.23)

You can now copy all the recorded places and times to the Windows clipboard. To do this select the Copy to Clipboard item from the File menu. Once you copy the data into the clipboard you can then paste it into other programs such as Notepad or Excel. The format of the clipboard data is the same as the file format that you specify in the Customize, Configuration Settings, Advanced dialog.

More Drive Options in Configuration Settings Dialog (added in version 1.23)

You can now select the target drive A, C, E, or Z with a single keystroke. You can specify any target drive by selecting Other (Alt+T) and typing the drive letter into the adjacent edit box.

Ability to limit bib number length to 0 or 1 digits (added in version 1.23)

You can now limit the length of a bib number to 0 or 1 digits in addition to 2, 3, 4, or 5. 

More power efficient Auto Backup of times (added in version 1.20)

When Auto Backup Times option is selected, Race Timer (Timer32.exe) now uses less CPU resources allowing for the power saving features of a computer and operating system to function. This is important when running on battery power. The Auto Backup Times option no longer negatively affects battery life as prior versions of Race Timer did. This change only affects the 32 bit version of Race Timer (Timer32.exe). The 16 bit version of Race Timer (Timer16.exe) uses the Windows 3.1 multimedia extensions (mmtask.tsk) for background multitasking which is a 16 bit process and is not efficient when it comes to power use. Timer16.exe may run on some configurations of Windows 32 bit operating systems (Windows 95,98,ME,NT,2000,XP,2003) but it will not run as efficiently as Timer32.exe.

Improved Time display (added in version 1.20)

The Time display updates closer to the actual turn over on the whole second. This change does not affect the timing process, but only changes the visible presentation of the time.

Ability to Edit Bib #’s in Main Timer Window (added in version 1.20)

To change the bib # for any place and time, first click on the place in the list of places. This will highlight the desired place and time in the list box. Then press the Associate Bib # push button (press the B key). This will associate the current bib number with the selected place. This action works only if the last thing you do is click on an item in the list of places. If you record a time, then the last recorded time becomes the place that will received the bib number by pressing the Associate Bib # push button.

Edit Times and Bib #’s dialog box (added in version 1.20)

The Edit Bib #’s dialog now allows for the editing of times. It is now called Edit Times and Bib #’s. To access the Edit Times and Bib #’s dialog you must have first selected Administrator level menus (Alt + C, A) and then select Edit from the Action menu (Alt + A, E).

Disable Dual Timing menu item (added in version 1.10)

There is a second new menu item in the Customize menu that is only available in Administrator mode. To access Administrator mode, select the Administrator Menu menu item from the Customize menu. The new menu item is called Disable Dual Timing. This item is checked by default every time Race Timer is started. When Disable Dual Timing is checked, Race Timer prevents you from entering dual timing mode.

Dual Timing (added in version 1.10)

Dual timing is a new feature of Race Timer introduced in version 1.10. Dual timing allows two operators (people) to use a single computer simultaneously as a team. One person uses the computer’s mouse and records all the times, but no bib numbers. A second person simultaneously uses the computer’s keyboard and performs the function of select timing (recording a subset of finishers, but getting a bib number with the times). The advantage of dual timing is that it segregates the two responsibilities of timing. The first responsibility is recording a time for every participant as they cross the finish line. The second responsibility is getting as many select times (times with bib numbers) as possible. Dual timing allows one person to focus on the first responsibility of recording times and the second person to concentrate solely on the second responsibility getting select times. This increases the accuracy of timing for high runner density races.

To put Race Timer into dual timing mode you must do two things. The first is to uncheck the Disable Dual Timing menu item in the Customize menu. The second is to press the F3 key. Once you enter dual timing mode, Race Timer is forced to be full screen and always on top. You can tell you are in dual timing mode by the message: “Dual Timing Mode: Left or Right Mouse Click to Record Time, Press F3 Key to Exit Dual Mode” that appears in place of the menu.

When in dual timing mode, the mouse no longer can be used in a normal manner to select menu items or push buttons. The mouse now acts like a pickle switch and will record a time every time you click either the left or right mouse button. It does not matter where the mouse cursor (pointer) is on the Race Timer screen, clicking a mouse button will always record a time. You cannot record a select time (a time with a bib number) using the mouse. To record a select time you must use the keyboard. In fact, you can only record select times with the keyboard. Pressing the enter key will not record a time unless you have first typed in a bib number. 

The intention of dual timing is to make the timing process easier for the operators doing the timing and thus yielding more accurate results. For all the participants that the person doing the select timing captures a select time for, the person doing the straight timing will have also recorded a time. This means that two times are recorded for some participants (the ones you have select times for). Race Timer resolves this by utilizing the time recorded with the mouse if the difference between the two times is less than one second. If the people doing the timing are sloppy and their times differ by greater than one second, then there will be extra times in the time data. This will force the person doing the results processing with a program such as Race Director to delete the extra times. To help the two people get the best results, make sure they are located close together and both are well aware of the exact finish line. A good method is to have the person doing the select timing with the keyboard sitting at a small table and the person doing the timing with the mouse standing behind them.

All the features on the main timing screen accessible by single keystroke are still available in dual mode. These include, Record, Delete, Swap, Associate, Save All, Save New, Append. Any features available through the menu only are not available in dual mode. To exit dual mode, press the F3 key. To re-enter dual mode press the F3 again.

Pressing the F3 key when the Disable Dual Timing item is checked has no affect. By default, Race Timer starts up with Disable Dual Timing checked. This prevents accidentally changing to dual timing mode when bumping the F3 key.

When using a mouse as a pickle switch in Dual Timing mode you must be careful with regards to creating a situation where you create static electricity. Depending upon the finish line environment you can create a situation where the person using the mouse can generate static electricity with regards to the computer and the person using the keyboard. A wireless mouse should avoid this. Some clothing and shoes seem to cause more static electricity than others. If you are sitting down, plastic chairs seem to cause more static electricity than metal. You will have to experiment with your finish line equipment and environment to see if you have a problem with static electricity. Problems reported occurred on a dry windy day using solid plastic lawn chairs and a standard PS/2 cabled mouse. Static electricity built up and discharged through the mouse to the computer causing the computer to freeze - a disaster for timing!

Other minor changes (added in version 1.10)

There are some minor bug fixes and changes in version 1.10. The automatic saving mode now better handles situations where the first save is timed to occur before any times are recorded. The Alt+P hot key for some items in the Configure dialog and Configure Advanced dialog inadvertently brought up the on-line help instead of selecting the dialog item. This has been fixed. The on-line help is disabled in situations where it interferes with the timing process.

Disable Exit menu item (added in version 1.09)

The Customize menu now has a new item, Disable Exit. This is a checkable item that when checked prevents exiting Race Timer. By default, when Race Timer first starts up, Disable Exit is not checked. This allows you to exit Race Timer at any time. When exiting, there is a message box prompt that verifies that you really want to exit Race Timer and end the timing session. For timing a race, we recommend that you disable the ability to exit by checking the Disable Exit menu item. This will prevent the person doing the timing from inadvertently exiting Race Timer. The method of exiting described in the User Guide does not apply to the current version of Race Timer and should be replaced with the preceding description.

Hints and suggestions

Certain computers will use battery power inefficiently when Auto Backup Times is selected in the Configuration Settings dialog. To conserve battery power make sure Auto Backup Times is not selected. The Auto Backup Times feature runs a background process that prevents the computer going into a power saving mode that some computers support and operating systems support.

Instead of using a mouse as a pickle switch for dual timing mode, you can purchase a pickle switch and wire it directly across one of the button switches in a mouse. This will require a person handy with a soldering iron and a sacrificial mouse. A pickle switch is better than a mouse for timing because it has a tactile feedback that gives the person doing the timing a good feel for when they actually press the button and record a time. A mouse button is more sensitive and harder to tell purely from feel when you actually click it. You can purchase a pickle switch from an electronics store such as Radio Shack. Again, plan your finish line to avoid static electricity when using a mouse or pickle switch in dual timing mode.

One final suggestion is to practice! The more familiar with Race Timer and the more you practice the better your timing results.

